Mt Xia: Technical Consulting Group

Business Continuity / Disaster Recovery / High Availability
Data Center Automation / Audit Response / Audit Compliance

-
Current Location
-

css
  GlobalSysAdmin
    AIX

-

digg Digg this page
del.icio.us Post to del.icio.us
Slashdot Slashdot it!


Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com

FREE Domain Registration
included with Web Site Hosting
Tools, Social Networking, Blog

www.siteox.com

The following document describes the procedure used to move the EGATE database preprod environment running on "ddcaaega01" and "ddcaaega02" to the new p590 LPAR's "ddcpocega01" and "ddcpocega02". This procedure was performed on April 29, 2005 and will be used again to move preprod back to the original machines. The purpose is to define the procedure required to move the EGATE production databases to the p590 LPAR's.

  • Generate HDLM SAN Disk identification document on current nodes

      ddcaaega01:
        cd /usr/DynamicLinkManager/bin
        lspv | grep dlmfdrv | grep -v dlmfdrvio |
        while read -- HDISK PVID VGNAME STATE
        do
          MAJOR=""
          LOC=""
          ls -l /dev/${VGNAME} 2>/dev/null |
            IFS="${IFS}," read -- PERMS LINKS OWNER GROUP MAJOR MINOR REMAIN
          print -- "\n${HDISK}  ${PVID}  ${VGNAME}  ${STATE}  ${MAJOR:+VGmajor#:${MAJOR}}"
          /usr/DynamicLinkManager/bin/dlnkmgr view -drv |
              grep " ${HDISK} " |
          while read -r -- LINE
          do
            print -r -- "${LINE}"
            print -r -- "${LINE}" | read -r -- DNBR DLMDISK DDISK LDEV
            LOC="${LOC}$( lscfg -l ${DDISK} | awk '{ print $2, $1 }' )\\n"
          done
          print -- "${LOC}"
        done
    

      ddcaaega02:
        cd /usr/DynamicLinkManager/bin
        lspv | grep dlmfdrv | grep -v dlmfdrvio |
        while read -- HDISK PVID VGNAME STATE
        do
          MAJOR=""
          LOC=""
          ls -l /dev/${VGNAME} 2>/dev/null |
            IFS="${IFS}," read -- PERMS LINKS OWNER GROUP MAJOR MINOR REMAIN
          print -- "\n${HDISK}  ${PVID}  ${VGNAME}  ${STATE}  ${MAJOR:+VGmajor#:${MAJOR}}"
          /usr/DynamicLinkManager/bin/dlnkmgr view -drv |
              grep " ${HDISK} " |
          while read -r -- LINE
          do
            print -r -- "${LINE}"
            print -r -- "${LINE}" | read -r -- DNBR DLMDISK DDISK LDEV
            LOC="${LOC}$( lscfg -l ${DDISK} | awk '{ print $2, $1 }' )\\n"
          done
          print -- "${LOC}"
        done
    

  • Request SAN disks be presented to new machines
  • Shutdown Databases on current nodes
  • Shutdown HACMP on current nodes

      ddcaaega01: 
        smitty clstop
    

      ddcaaega02: 
        smitty clstop
    

  • Varyoff any remaining non-rootvg volume groups
  • On new nodes, save current state of disks

      ddcpocega01: 
        lspv > /tmp/lspv.out
    

      ddcpocega02: 
        lspv > /tmp/lspv.out
    

  • Configure SAN disks
  • Run configuration manager to pull in all SAN disks

      ddcpocega01: 
        cfgmgr
    

      ddcpocega02: 
        cfgmgr
    

  • Clear persistant reserves on all SAN disks

      ddcpocega01: 
        cd /usr/DynamicLinkManager/bin
        for i in $( lspv | awk '{ print $1 }' | grep "^hdisk" )
        do
          ./dlmpr -c ${i}
        done
    

      ddcpocega02: 
        cd /usr/DynamicLinkManager/bin
        for i in $( lspv | awk '{ print $1 }' | grep "^hdisk" )
        do
          ./dlmpr -c ${i}
        done
    

  • Remove all SAN disks and rediscover to obtain PVID's

      ddcpocega01: 
        for i in $( lspv | awk '{ print $1 }' )
        do
          rmdev -Rdl ${i}
        done
        cfgmgr
    

      ddcpocega02: 
        for i in $( lspv | awk '{ print $1 }' )
        do
          rmdev -Rdl ${i}
        done
        cfgmgr
    

  • Check SAN disks against list of PVID's then import VG's using OCIDR.

      ddcpocega01:
        cd /usr/lpp/dr/ddcpocega01
        ./OCIDR -I config
    

      ddcpocega02:
        cd /usr/lpp/dr/ddcpocega02
        ./OCIDR -I config
    

  • Varyon the non-concurrent volume groups and set to automatically varyon at boot time.

      ddcpocega01:
        varyonvg oradb01vg01
        chvg -a y oradb01vg01
        varyonvg oradb01vg02
        chvg -a y oradb01vg02
    

      ddcpocega02:
        varyonvg oradb02vg01
        chvg -a y oradb02vg01
        varyonvg oradb02vg02
        chvg -a y oradb02vg02
    

  • Set the database filesystems to automatically mount at boot time.

      ddcpocega01:
        chfs -A y /u01001
        chfs -A y /u01002
        chfs -A y /backup
    

      ddcpocega02:
        chfs -A y /u01001
        chfs -A y /u01002
        chfs -A y /backup
    

  • Modify the /etc/hosts file to reflect the new hostnames

      ddcpocega01:
        vi /etc/hosts
    

      ddcpocega02:
        vi /etc/hosts
    

  • Modify HACMP to include the new concurrent volume groups

      ddcpocega01:
        oracon01vg oracon02vg oracon03vg oracon04vg
    

  • Sync and verify, then start the HACMP configuration.

    ddcpocega01:
        Start HACMP
    

    ddcpocega02:
        Start HACMP
    

  • Change ownership of oracle LV's

      ddcpocega01: 
        chown oracle:dba /dev/*orarp*
    

      ddcpocega02: 
        chown oracle:dba /dev/*orarp*
    

  • Change the number of processes per user to 3000

      ddcpocega01: 
        chdev -l sys0 -a maxuproc=3000
    

      ddcpocega02: 
        chdev -l sys0 -a maxuproc=3000
    

  • Mount the first Oracle CD from the NIM server and run the "rootpre.sh" script to set permissions and such.

      mdcapnim01: 
        exportfs -i -o 'root=*' /export/cdimages/Oracle8.1.7_Disk1
    

      ddcpocega01: 
        mount mdcapnim01:/export/cdimages/Oracle8.1.7_Disk1 /mnt
        cd /mnt
        ./rootpre.sh
        cd /tmp
        umount /mnt
    

      ddcpocega02: 
        mount mdcapnim01:/export/cdimages/Oracle8.1.7_Disk1 /mnt
        cd /mnt
        ./rootpre.sh
        cd /tmp
        umount /mnt
    

      mdcapnim01:
        exportfs -u /export/cdimages/Oracle8.1.7_Disk1
    

  • Notify database and application group the machines are ready
  • Contact Doug Lemons to make DNS changes

      CNAME: point ddcaaega01 to ddcpocega01
      CNAME: point ddcaaega02 to ddcpocega02
    

-
Move Egate Preprod
-
 


FREE Domain Registration
included with Web Site Hosting
Tools, Social Networking, Blog

www.siteox.com

Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com