# Start with a server built using the standard build procedure:
http://www.mtxia.com/js/GlobalSysAdmin/AIX/builddoc.shtml
Then make the following modifications:
# Unconfigure all ethernet adapters
lscfg -l ent*
for i in 9 8 7 6 5 4 3 2 1 0
do
ifconfig en${i} down
ifconfig en${i} detach
ifconfig et${i} down
ifconfig et${i} detach
rmdev -Rdl ent${i}
rmdev -Rdl en${i}
rmdev -Rdl et${i}
done
ifconfig -a
lsdev -Cc adapter | grep ent
# Rediscover all ethernet adapters
cfgmgr
lsdev -Cc adapter | grep ent
lsdev -C | grep inet
lsdev -C | grep lo
lscfg -l ent*
# turn off the chksum_offload parameter on all adapters
for i in 5 4 3 2 1 0
do
lsattr -El ent${i} | grep chksum_offload
chdev -l ent${i} -a chksum_offload=no
chdev -l ent${i} -a chksum_offload=no -P
lsattr -El ent${i} | grep chksum_offload
done
# Configure etherchannel devices
for i in 4 5 6 7 8
do
rmdev -Rdl ent${i}
rmdev -Rdl en${i}
rmdev -Rdl et${i}
done
if mkdev -c adapter -s pseudo -t ibm_ech \
-a adapter_names=ent1 \
-a netaddr=146.61.122.254 \
-a backup_adapter=ent0
then
/usr/lib/methods/defif
fi
if mkdev -c adapter -s pseudo -t ibm_ech \
-a adapter_names=ent3 \
-a netaddr=146.61.124.254 \
-a backup_adapter=ent2
then
/usr/lib/methods/defif
fi
lsdev -Cc adapter | grep ent
lsattr -El inet0
# Now define the IP addresses to be used by this SAP Sandbox Instance.
# vi /etc/hosts
192.168.30.238 mxfadsap01-boot.tu.com mxfadsap01-boot
146.61.122.238 mxfadsap01.tu.com mxfadsap01
146.61.122.239 mxfadsap01-pers.tu.com mxfadsap01-pers
146.61.124.60 mxfadsap01-man.tu.com mxfadsap01-man
146.61.122.241 mxfadsap01-rg02.tu.com mxfadsap01-rg02 ssmdatu1.tu.com ssmdatu1
192.168.30.10 mxfadsap02-boot.tu.com mxfadsap02-boot
146.61.122.10 mxfadsap02.tu.com mxfadsap02
146.61.122.11 mxfadsap02-pers.tu.com mxfadsap02-pers
146.61.124.61 mxfadsap02-man.tu.com mxfadsap02-man
146.61.122.242 mxfadsap01-rg03.tu.com mxfadsap01-rg03 sxidatu1.tu.com sxidatu1
192.168.30.12 mxfadsap03-boot.tu.com mxfadsap03-boot
146.61.122.12 mxfadsap03.tu.com mxfadsap03
146.61.122.13 mxfadsap03-pers.tu.com mxfadsap03-pers
146.61.124.62 mxfadsap03-man.tu.com mxfadsap03-man
146.61.122.240 mxfadsap01-rg01.tu.com mxfadsap01-rg01 isudatu1.tu.com isudatu1
192.168.30.14 mxfadsap04-boot.tu.com mxfadsap04-boot
146.61.122.14 mxfadsap04.tu.com mxfadsap04
146.61.122.15 mxfadsap04-pers.tu.com mxfadsap04-pers
146.61.124.63 mxfadsap04-man.tu.com mxfadsap04-man
146.61.122.243 mxfadsap01-rg04.tu.com mxfadsap01-rg04 crmdatu1.tu.com crmdatu1
192.168.30.16 mxfadsap05-boot.tu.com mxfadsap05-boot
146.61.122.16 mxfadsap05.tu.com mxfadsap05
146.61.122.17 mxfadsap05-pers.tu.com mxfadsap05-pers
146.61.124.64 mxfadsap05-man.tu.com mxfadsap05-man
146.61.122.245 mxfadsap01-rg06.tu.com mxfadsap01-rg06 sepdatu1.tu.com sepdatu1
192.168.30.18 mxfadsap06-boot.tu.com mxfadsap06-boot
146.61.122.18 mxfadsap06.tu.com mxfadsap06
146.61.122.19 mxfadsap06-pers.tu.com mxfadsap06-pers
146.61.124.65 mxfadsap06-man.tu.com mxfadsap06-man
146.61.122.246 mxfadsap01-rg07.tu.com mxfadsap01-rg07 skmdatu1.tu.com skmdatu1
146.61.122.244 mxfadsap01-rg05.tu.com mxfadsap01-rg05 sbwdatu1.tu.com sbwdatu1
# Assign the designated IP address to this SAP sandbox instance:
smitty tcpip
# Install bos.adt.* filesets and update to the latest levels.
installp -agXd /usr/sys/inst.images bos.adt
# Install the 64 bit Java filesets then update to the latest levels.
installp -agX -d /usr/sys/inst.images \
Java14_64.debug 1.4.0.0 \
Java14_64.ext.commapi 1.4.0.0 \
Java14_64.ext.javahelp 1.4.0.0 \
Java14_64.license 1.4.0.0 \
Java14_64.samples 1.4.0.0 \
Java14_64.sdk 1.4.0.0 \
Java14_64.source 1.4.0.0
lslpp -lc |
awk -F ":" '{print $2}' |
tail -n +2 |
grep 'Java14_64' > /tmp/lslpp
installp -agXd /usr/sys/inst.images -e /tmp/install.log -f /tmp/lslpp
# Add directory exclusions for mksysb backups to /etc/exclude.rootvg.
print '^./tmp/\n./usr/websm/pc_client/\n./usr/sys/inst.images' > /etc/exclude.rootvg
# Set the SCSI MPIO priority for each virtual disk.
/usr/local/scripts/vscsiPriority.ksh -vori 20
# create 20 gb swap space, the following command increases hd6 by 18 GB:
chps -s 192 hd6
Create the SAP groups and users.
#!/usr/bin/ksh93
GNAMES=( sapsys oper dba hagsuser )
mkgroup -a id=11500 ${GNAMES[0]}
mkgroup -a id=11501 ${GNAMES[1]}
mkgroup -a id=11502 ${GNAMES[2]}
HAGUID=$( print -- ${GNAMES[3]} | sum -r )
HAGUID="${HAGUID//[!0-9]/}"
print -- mkgroup -a id=${HAGUID} ${GNAMES[3]}
mkgroup -a id=${HAGUID} ${GNAMES[3]}
#!/usr/bin/ksh93
SNAMES=( ssmdatu1 SM1 )
UNAMES=( sm1adm orasm1 )
mkuser home=/${SNAMES[0]}/oracle/${SNAMES[1]} id=11521 shell=/bin/csh ${UNAMES[0]}
chuser gecos="SAP Admin User" ${UNAMES[0]}
chuser pgrp=dba ${UNAMES[0]}
mkuser home=/${SNAMES[0]}/oracle/${SNAMES[1]} id=11621 shell=/bin/csh ${UNAMES[1]}
chuser gecos="SAP Admin User" ${UNAMES[1]}
chuser pgrp=dba ${UNAMES[1]}
# Set ulimits to unlimited as follows:
#!/usr/bin/ksh93
UNAMES=( root sm1adm orasm1 )
for UNAME in "${UNAMES[@]}"
do
chuser rss_hard=-1 ${UNAME}
chuser stack_hard=-1 ${UNAME}
chuser fsize=-1 ${UNAME}
chuser cpu=-1 ${UNAME}
chuser data=-1 ${UNAME}
chuser rss=-1 ${UNAME}
chuser stack=-1 ${UNAME}
done
IFS=','
chgrpmem -m = "${UNAMES[*]}" sapsys
chgrpmem -m = "${UNAMES[*]}" oper
chgrpmem -m = "${UNAMES[*]}" dba
chgrpmem -m = "${UNAMES[*]}" hagsuser
cat /etc/group
# AIX tuning parameters
chdev -l sys0 -a maxuproc=4096
vmo -po maxclient%=50
vmo -po maxperm%=50
vmo -po minperm%=3
vmo -po lru_file_repage=0
vmo -po strict_maxclient=1
vmo -po strict_maxperm=0
vmo -po maxfree=10880
vmo -po minfree=9600
vmo -ro memory_affinity=0
vmo -o maxclient%
vmo -o maxperm%
vmo -o minperm%
vmo -o lru_file_repage
vmo -o strict_maxclient
vmo -o strict_maxperm
vmo -o minfree
vmo -o maxfree
vmo -o memory_affinity
# Set the queue depth for each virtual disk to match the VIO server # queue depth, which at the time of this writing is "16":
for i in $( lsdev -Cc disk -F name )
do
print "${i}: $( lsattr -El ${i} -a queue_depth)"
chdev -l ${i} -a queue_depth=16
chdev -l ${i} -a queue_depth=16 -P
print "${i}: $( lsattr -El ${i} -a queue_depth)"
done
chdev -l sys0 -a maxuproc=3000 -P
chdev -l aio0 -a maxreqs=16386 -P
chdev -l aio0 -a maxservers=300 -P
chdev -l aio0 -a minservers=150 -P
chdev -l aio0 -a autoconfig=available -P
mkdev -l aio0
lsdev -l aio0
lsattr -El aio0
Change the name of the existing "/usr/sap/trans
" file
system and append a "_local
" extension to the directory
name.
chfs -m /crmdatu1/usr/sap/trans_local /crmdatu1/usr/sap/trans
Establish an NFS mounted file system from the "ssmdatu1" system for the "/usr/sap/trans" directory.
NFSSRV[0]="ssmdatu1"
EXPT[0]="/ssmdatu1/usr/sap/trans"
MTPT[0]="/crmdatu1/usr/sap/trans"
umount ${MTPT[0]}
/usr/sbin/rmnfsmnt -f "${MTPT[0]}" -B
/usr/sbin/mknfsmnt -f "${MTPT[0]}" -d "${EXPT[0]}" -h "${NFSSRV[0]}" -M sys -I -a -t rw -w bg -Y -Z -X -H -j -q -g
mount ${MTPT[0]}
grep -p "${MTPT[0]}:" /etc/filesystems
df
# check settings on each SAP LPAR
ulimit -a
lsps -a
lsdev -l aio0
lsattr -El aio0
for i in $( lsdev -Cc disk -F name )
do
print "${i}: $( lsattr -El ${i} | grep queue)"
done
lsattr -El sys0 -a maxuproc
vmo -o maxclient%
vmo -o maxperm%
vmo -o minperm%
vmo -o lru_file_repage
vmo -o strict_maxclient
vmo -o strict_maxperm
vmo -o minfree
vmo -o maxfree
vmo -o memory_affinity
lslpp -l | grep bos.adt.debug
ls -ld /oracle /sapmnt /usr/sap
ps -ef | grep -i xm
lsgroup hagsuser
# Shutdown the system and reboot to activate the changes made by this procedure:
shutdown -Fr