Home About BC DR HA Support Training Download
You are here: Home/ Standards/ MQSeries/ Please Login or Register

-
Current Location
-

js
  Standards
    MQSeries
-
AIX Admin Methodology
Global Consolidation Project
All AIX admins should join
www.aixexpert.com


Join our LinkedIn Group
AIX Advanced Technical Experts
Contract Opportunities

www.LinkedIn.com

-
digg Digg this page
del.icio.us Post to del.icio.us
Slashdot Slashdot it!


LPAR Leasing
Lease an AIX / i5 LPAR
Reduce your costs

www.mtxia.com

Server Leasing
Lease a Server off-site
Reduce your costs

www.mtxia.com

Data Center Automation
Business Continuity and DR
Virtualization/Consolidation

www.mtxia.com

HMC Service
Hardware Management Console
Manage Remote AIX / i5 LPARs

www.siteox.com

Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com

Disaster Recovery
Small Business Oriented
Off-Site Facilities

www.mtxia.com

IBM pSeries / iSeries
Reduce your Costs
Off-Site Server Hosting

www.mtxia.com

The following document provides step-by-step instructions for reconfiguring an existing installation of MQSeries into an HACMP compatible installation of MQSeries. These instructions assume there is a volume group called "<Machine Identifier>datavg" which exists on a shared external disk array. The "<Machine Identifier>" portion of the volume group name is a string of characters which uniquely identifies the machine with which the volume group is normally associated. As an example, this document describes a two machine, mutual failover cluster using machine names of "mtxeai01" and "mtxeai02".

The volume group, logical volume and file system naming standards used in this document conform to the standardized methodology detailed in the document titled "Filesystem Naming". Two logical volumes are created during this procedure which occupy 2.5 GB of disk space. The amount of disk space used for each logical volume can be changed to suit the implementation requirements.


  1. mtxeai02: Run the following script, which will create and modify the various file systems required for the implementation of MQSeries in an AIX HACMP environment:
    
    #!/bin/ksh
    ################################################################
    # 
    # Customize the following shell variables for each 
    # machine on which this script is run.
    # 
    ################################################################
    PPSIZE="16"
    DISKNBR="power1"
    MACHID="eai02"
    QMNAME="YYEAIAIX"
    ################################################################
    
    umount /mtx${MACHID}/ibm/mqm/${QMNAME}/data
    umount /mtx${MACHID}/ibm/mqm/${QMNAME}/log
    rmfs /mtx${MACHID}/ibm/mqm/${QMNAME}/data
    rmfs /mtx${MACHID}/ibm/mqm/${QMNAME}/log
    
    #  Logical Volume: /dev/${MACHID}datalv (edge)
    mklv -y${MACHID}datalv -ae ${MACHID}datavg \
      $(( 750 / ${PPSIZE} )) hdisk${DISKNBR}
    
    #  Logical Volume: /dev/${MACHID}logslv (center)
    mklv -y${MACHID}logslv -ac ${MACHID}datavg \
      $(( 1750 / ${PPSIZE} )) hdisk${DISKNBR}
    
    #  File System: /mtx${MACHID}/ibm/mqm/${QMNAME}/data
    crfs -v jfs -a bf=true -d${MACHID}datalv \
      -m/mtx${MACHID}/ibm/mqm/${QMNAME}/data -Ayes -prw \
      -tno -a nbpi=4096 -a ag=64
    mount /mtx${MACHID}/ibm/mqm/${QMNAME}/data
    
    #  File System: /mtx${MACHID}/ibm/mqm/${QMNAME}/log
    crfs -v jfs -a bf=true -d${MACHID}logslv \
      -m/mtx${MACHID}/ibm/mqm/${QMNAME}/log -Ayes -prw \
      -tno -a nbpi=4096 -a ag=64
    mount /mtx${MACHID}/ibm/mqm/${QMNAME}/log
    
    ln -s /mtx${MACHID}/ibm/mqm /MQHA
    chfs -An /mtx${MACHID}/ibm/mqm/${QMNAME}/data
    chfs -An /mtx${MACHID}/ibm/mqm/${QMNAME}/log
    chvg -a'n' -Q'y' -x'n' ${MACHID}datavg 
    chown -R mqm.mqm /mtx${MACHID}/ibm/mqm/${QMNAME}
    
    
    
  2. mtxeai02: Create the MQSeries HACMP script top level directory:


    $ ln -s /mtxeai02/ibm/mqm /MQHA

  3. mtxeai01: Create the MQSeries HACMP script top level directory and the Queue Manager directory for the remote Queue Manager.


    $ ln -s /mtxeai01/ibm/mqm /MQHA
    $ ln -s /mtxeai02/ibm/mqm/YYEAIAIX /mtxeai01/ibm/mqm/YYEAIAIX

  4. mtxeai02: Copy the HA scripts into the /MQHA/bin directory


    $ cp /usr/sys/inst.images/mqseries/* /MQHA/bin
    $ chown mqm.mqm /MQHA/bin/ha*
    $ chmod 755 /MQHA/bin/ha*

  5. mtxeai02: Create the MQSeries queue manager using the HACMP scripts:


    $ export MQHAFSDATA=/mtxeai02/ibm/mqm/P1EAIAIX/data
    $ export MQHAFSLOG=/mtxeai02/ibm/mqm/P1EAIAIX/log
    $ cd /MQHA/bin
    $ ./hacrtmqm -ll -lf 16384 -lp 10 -ls 5 -q \
      -u SYSTEM.DEAD.LETTER.QUEUE YYEAIAIX

  6. mtxeai01: Create the corresponding links on the failover side, login as "mqm":


    $ su - mqm -c halinkmqm YYEAIAIX YYEAIAIX /MQHA/YYEAIAIX/data

  7. mtxeai02: Edit the initialization file and remove all duplicate or inappropriate references to queue managers:


    $ me /var/mqm/mqs.ini

  8. mtxeai01: Edit the initialization file and remove all duplicate or inappropriate references to queue managers:


    $ me /var/mqm/mqs.ini

  9. mtxeai02: login as root and start the Queue manager using the HACMP scripts:


    $ cd /MQHA/bin
    $ ./hamqm_start YYEAIAIX

  10. mtxeai02: change the file systems and volume group to NOT automatically startup at system boot time:


    $ chfs -An /mtxeai02/ibm/mqm/YYEAIAIX/data
    $ chfs -An /mtxeai02/ibm/mqm/YYEAIAIX/log
    $ chvg -a'n' -Q'y' -x'n' eai02datavg

  11. mtxeai01: HACMP command to start the cluster environment:


    $ /usr/sbin/cluster/etc/rc.cluster -boot '-N' '-b' '-i'

  12. mtxeai02: HACMP command to start the cluster environment:


    $ /usr/sbin/cluster/etc/rc.cluster -boot '-N' '-b' '-i'

-
mtxeai02 MQSeries
-
 


LPAR Leasing
Lease an AIX / i5 LPAR
Reduce your costs

www.mtxia.com

Server Leasing
Lease a Server off-site
Reduce your costs

www.mtxia.com

Data Center Automation
Business Continuity and DR
Virtualization/Consolidation

www.mtxia.com

HMC Service
Hardware Management Console
Manage Remote AIX / i5 LPARs

www.siteox.com

Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com

FREE Domain Registration
included with Web Site Hosting
Tools, Social Networking, Blog

www.siteox.com

Disaster Recovery
Small Business Oriented
Off-Site Facilities

www.mtxia.com

IBM pSeries / iSeries
Reduce your Costs
Off-Site Server Hosting

www.mtxia.com