Home About BC DR HA Support Training Download
You are here: Home/ GlobalSysAdmin/ Power5/ Please Login or Register

-
Current Location
-

js
  GlobalSysAdmin
    Power5
-
AIX Admin Methodology
Global Consolidation Project
All AIX admins should join
www.aixexpert.com


Join our LinkedIn Group
AIX Advanced Technical Experts
Contract Opportunities

www.LinkedIn.com

-
digg Digg this page
del.icio.us Post to del.icio.us
Slashdot Slashdot it!


LPAR Leasing
Lease an AIX / i5 LPAR
Reduce your costs

www.mtxia.com

Server Leasing
Lease a Server off-site
Reduce your costs

www.mtxia.com

Data Center Automation
Business Continuity and DR
Virtualization/Consolidation

www.mtxia.com

HMC Service
Hardware Management Console
Manage Remote AIX / i5 LPARs

www.siteox.com

Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com

Disaster Recovery
Small Business Oriented
Off-Site Facilities

www.mtxia.com

IBM pSeries / iSeries
Reduce your Costs
Off-Site Server Hosting

www.mtxia.com

The following example procedure is specific to an LPAR on the 146.61.122.0 subnet, but is representative of how to configure etherchannels on all virtual LPAR's utilizing network adapters being provided from dual VIO servers.



# login to the client LPAR through the HMC console

# On the client LPAR, unconfigure all ethernet adapters
lscfg -l ent*
for i in 9 8 7 6 5 4 3 2 1 0
do
  ifconfig en${i} down
  ifconfig en${i} detach
  ifconfig et${i} down
  ifconfig et${i} detach
  rmdev -Rdl ent${i}
  rmdev -Rdl en${i}
  rmdev -Rdl et${i}
done
ifconfig -a
lsdev -Cc adapter | grep ent


# Rediscover all ethernet adapters
cfgmgr
lsdev -Cc adapter | grep ent
lsdev -C | grep inet
lsdev -C | grep lo
lscfg -l ent*


# turn off the chksum_offload parameter on all adapters
for i in 9 8 7 6 5 4 3 2 1 0
do
  lsattr -El ent${i} | grep chksum_offload
  chdev -l ent${i} -a chksum_offload=no
  chdev -l ent${i} -a chksum_offload=no -P
  lsattr -El ent${i} | grep chksum_offload
done


# Configure etherchannel devices, begin by removing existing adapters
for i in 4 5 6 7 8
do
  rmdev -Rdl ent${i}
  rmdev -Rdl en${i}
  rmdev -Rdl et${i}
done

# ent0 and ent1 should represent virtual ethernet adapters shared
# from the VIO servers via slots 500 and 505.
# The netaddr points to the subnet gateway for the boot/service 
# network - used for health check.
if mkdev -c adapter -s pseudo -t ibm_ech \
   -a adapter_names=ent0 \
   -a netaddr=146.61.122.254 \
   -a backup_adapter=ent1
then
  /usr/lib/methods/defif
fi

# ent2 and ent3 should represent virtual ethernet adapters shared
# from the VIO servers via slots 850 and 855.
# The netaddr points to the subnet gateway for the "man" network, 
# used for health check.
if mkdev -c adapter -s pseudo -t ibm_ech \
   -a adapter_names=ent2 \
   -a netaddr=146.61.124.254 \
   -a backup_adapter=ent3
then
  /usr/lib/methods/defif
fi
lsdev -Cc adapter | grep ent

# configure IP addresses on etherchannels
smitty tcpip

# Assign the LPAR's boot address to ent4
# Assign the LPAR's man address to ent5

-
LPAR Ether Config
-
 


LPAR Leasing
Lease an AIX / i5 LPAR
Reduce your costs

www.mtxia.com

Server Leasing
Lease a Server off-site
Reduce your costs

www.mtxia.com

Data Center Automation
Business Continuity and DR
Virtualization/Consolidation

www.mtxia.com

HMC Service
Hardware Management Console
Manage Remote AIX / i5 LPARs

www.siteox.com

Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com

FREE Domain Registration
included with Web Site Hosting
Tools, Social Networking, Blog

www.siteox.com

Disaster Recovery
Small Business Oriented
Off-Site Facilities

www.mtxia.com

IBM pSeries / iSeries
Reduce your Costs
Off-Site Server Hosting

www.mtxia.com