Home About BC DR HA Support Training Download
You are here: Home/ GlobalSysAdmin/ Power5/ Please Login or Register

-
Current Location
-

js
  GlobalSysAdmin
    Power5
-
AIX Admin Methodology
Global Consolidation Project
All AIX admins should join
www.aixexpert.com


Join our LinkedIn Group
AIX Advanced Technical Experts
Contract Opportunities

www.LinkedIn.com

-
digg Digg this page
del.icio.us Post to del.icio.us
Slashdot Slashdot it!


LPAR Leasing
Lease an AIX / i5 LPAR
Reduce your costs

www.mtxia.com

Server Leasing
Lease a Server off-site
Reduce your costs

www.mtxia.com

Data Center Automation
Business Continuity and DR
Virtualization/Consolidation

www.mtxia.com

HMC Service
Hardware Management Console
Manage Remote AIX / i5 LPARs

www.siteox.com

Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com

Disaster Recovery
Small Business Oriented
Off-Site Facilities

www.mtxia.com

IBM pSeries / iSeries
Reduce your Costs
Off-Site Server Hosting

www.mtxia.com

Create LPAR on HMC

Use the following Korn Shell 93 script to create the LPAR from any desktop with ssh access to the controlling HMC.

Script to create LPAR


NIM Configuration and Setup

Add the interface IP addresses and hostname of the system being built.

vi /etc/hosts

Add a NIM Network if the server being built is installed on a new network.

nim -o define -t ent \
-a net_addr=146.61.xxx.0 \
-a snm=255.255.255.0 \
-a routing1=default 146.61.xxx.254 xxx_network

Define a Machine within NIM, edit hostname and network information for specific system being built.

nim -o define -t standalone \
-a if1="xxx_network hostname-pers 0 ent" \
-a cable_type1=tp \
-a platform=chrp \
-a netboot_kernel=mp hostname-pers

Initiate a BOS RTE Installation from NIM

nim -o bos_inst -a source=rte -a lpp_source=aix_5300-03 \
-a spot=aixspot_5300-03 -a no_client_boot=yes \
-a resolv_conf=resolv_conf -a accept_licenses=yes \
-a installp_flags=-cNgXY hostname

OR

Initiate a MKSYSB Installation from NIM

Define a mksysb resource for Installation within NIM
nim -o define -t mksysb -a server=master \
-a location=/export/mksysb/mksysb_hostname mksysb_hostname

Edit the server specific information to initiate a mksysb install.
nim -o bos_inst  -a spot=aixspot_5300-03 -a lpp_source=aix_5300-03 \
-a mksysb=mksysb_hostname -a resolv_conf=resolv_conf \
-a accept_licenses=yes -a no_client_boot=yes \
-a installp_flags=cNgXY hostname-pers

AIX Postbuild Installation Tasks.

Install Additional AIX Filesets.

mount mx0apnim01:/export/lpp_source/aix/aix_5300-03/installp/ppc /mnt
cd /mnt
/usr/lib/instl/sm_inst installp_cmd -a -l -d '.' -f '@ 5.3.0.0  Base Application Development Math Lib
rary                   @@I:bos.adt.libm 5.3.0.0,@ 5.3.0.0  System Calls Application Development Toolk
it                @@I:bos.adt.syscalls 5.3.0.0,@ 5.3.0.0  Enhanced Concurrent Logical Volume Manager
                 @@I:bos.clvm.enh 5.3.0.0,@ 2.4.0.0  RSCT Basic Function (HACMP/ES Support)
            @@I:rsct.basic.hacmp 2.4.0.0,@ 2.4.0.0  RSCT Basic Function (PSSP Support)
           @@I:rsct.basic.sp 2.4.0.0,@ 2.4.0.0  RSCT Event Management Basic Function (HACMP/ES Suppor
t)     @@I:rsct.compat.basic.hacmp 2.4.0.0,@ 2.4.0.0  RSCT Event Management Basic Function (PSSP Supp
ort)         @@I:rsct.compat.basic.sp 2.4.0.0,@ 2.4.0.0  RSCT Event Management Client Function (HACMP
/ES Support)    @@I:rsct.compat.clients.hacmp 2.4.0.0,@ 2.4.0.0  RSCT Event Management Client Functio
n (PSSP Support)        @@I:rsct.compat.clients.sp 2.4.0.0'  '-c' '-N' '-g' '-X'   '-V2'  '-Y'
cd /tmp/
umount /mnt

Install TSM Client Code.

Please refer to TSM Compatability Section for Correct TSM Version and Configuration.

mount mx0apnim01:/export/lpp_source/tsm /mnt2
cd /mnt2/tsmclient_5234_64bit
/usr/lib/instl/sm_inst installp_cmd -a -l -d . -f all -c -N -g -X -Y
cd /tmp
umount /mnt2

Install Tivoli TEC Client Code.

mount mx0apnim01:/export/lpp_source/tec /mnt2
cd /mnt2
tar -xvf opt_lcf_tivoli.tar
tar -xvf etc_tivoli.tar
rm -f /opt/Tivoli/lcf/dat/1/lcf.dat
rm -f /opt/Tivoli/lcf/dat/1/lcf.id
cd /tmp
umount /mnt2

Install AIX Performance Toolbox Client Code.

mount mx0apnim01:/export/lpp_source/performance /mnt2
cd /mnt2/perfaide_3100
/usr/lib/instl/sm_inst installp_cmd -a -l -d . -f all -c -N -g -X -Y
cd /mnt2/perftoolbox_3100
/usr/lib/instl/sm_inst installp_cmd -a -l -d . -f all -c -N -g -X -Y
cd /tmp
umount /mnt2

Install Unix Tools and Utilities.

mount mx0apnim01:/export/lpp_source/toolbox /mnt2
cd /mnt2/linuxapps_200411/RPMS/ppc
rpm -i lsof-4.61-3.aix5.1.ppc.rpm
rpm -i openssl-0.9.7d-1.aix5.1.ppc.rpm
rpm -i openssl-doc-0.9.7d-1.aix5.1.ppc.rpm
rpm -i lynx-2.8.4-1ssl.aix4.3.ppc.rpm
rpm -i screen-3.9.10-2.aix4.3.ppc.rpm
rpm -i sudo-1.6.7p5-2.aix5.1.ppc.rpm
rpm -i unzip-5.51-1.aix5.1.ppc.rpm
cd /tmp
umount /mnt2

Install Unix Open SSH Code.

mount mx0apnim01:/export/lpp_source/aix/exppack_5300 /mnt2
cd /mnt2
/usr/lib/instl/sm_inst installp_cmd -a -l -d '.' \
-f 'openssh.base ALL @@I:openssh.base _all_filesets,\
openssh.license ALL @@I:openssh.license _all_filesets,\
openssh.man.en_US ALL @@I:openssh.man.en_US _all_filesets'  \
-c -N -g -X -Y
cd /tmp
umount /mnt2

Install Unix KSH93 Shell Code.

cd /usr/bin
ftp -n <<"ENDFTP"
open mx0apnim01
user root password
cd /usr/bin
binary
prompt
hash
get ksh93.att
quit
ENDFTP
cd /usr/bin
ls -l ksh93.att
chmod 555 /usr/bin/ksh93.att
chown bin:bin /usr/bin/ksh93.att
ls -l ksh93.att
cd /tmp

Additional Crontab Entries for Root User.

crontab -e
0 5 * * * /usr/local/docitweb/docitweb.run > /dev/null 2>&1

Install Docitweb Code.

scp username@eperf:/usr/local/docitweb_serv.tar.gz /tmp
mkdir -p /usr/local
cd /usr/local
gzip -cd /tmp/docitweb_serv.tar.gz | tar -xvf -
ls -alrt

Install Unix XMON Code.

#!/usr/bin/ksh
NEWXMONID=$( echo "xmon" | sum | sed -e "s/ //g" )
if id xmon
then
  OLDXMONID="$( id xmon | awk '{ print $1 }' | sed -e "s/[^0-9]//g" )"
  [[ -f /home/xmon/.rhosts ]] && chown xmon:staff /home/xmon/.rhosts
  find / -user xmon -exec ls -ld {} \; 2>/dev/null
  ps -ef | grep -i xmon
  NEWXMONID=$( echo "xmon" | sum | sed -e "s/ //g" )
  chuser id=${NEWXMONID} xmon
  id xmon
  find /home -user xmon -exec ls -ld {} \;
  find /home -user ${OLDXMONID} -exec ls -ld {} \;
  find /home -user ${OLDXMONID} -exec chown xmon:staff {} \; -print
  find /home -user xmon -exec ls -ld {} \;
  unset OLDXMONID
else
  mkuser id="${NEWXMONID}" pgrp='staff' gecos='xmonitor ' xmon
  pwdadm -c xmon
fi
cd /home
[[ -d /home/xmon ]] &&
  chown -R xmon:staff xmon
cd /home/xmon &&
  [[ ! -f .rhosts ]]  &&
  echo "eperf cricket" > .rhosts &&
  echo "eperf.tu.com cricket" >> .rhosts
  echo "eperf root" >> .rhosts
  echo "eperf.tu.com root" >> .rhosts
chown xmon.staff /home/xmon/.rhosts
chmod 600 /home/xmon/.rhosts
pwd
cat /home/xmon/.rhosts
ls -la

Install Unix INQ Utility Code.

#!/usr/bin/ksh
mkdir -p /usr/local/sbin
mount mx0apnim01:/export/scripts /mnt
cp -p /mnt/EMC/INQ/v5.3.0.0/inq.aix64_51 /usr/local/sbin
umount /mnt
mv /usr/local/sbin/inq.aix64_51 /usr/local/sbin/inq
chmod 755 /usr/local/sbin/inq
ls -l /usr/local/sbin/inq

Install Unix NMON Utility Code.

#!/usr/bin/ksh
mount mx0apnim01:/export/scripts /mnt
cp -p /mnt/NMON/nmon10p/install/nmon10p_install-to-sbin.tar /usr/sbin
umount /mnt
cd /usr/sbin
tar -xvf nmon10p_install-to-sbin.tar
rm -f /usr/sbin/nmon10p_install-to-sbin.tar
ls -l /usr/sbin/nmon*
sleep 2
/usr/sbin/nmon

Create System Dump Device

!/usr/bin/ksh
mklv -y hd7x -t sysdump rootvg xx
sysdumpdev -p /dev/hd7x
sysdumpdev -l

Change Disk Attribute for Health Check.

 in $(lsdev -Cc disk -F name )
 do
  chdev -l ${i} -a hcheck_interval=20 -P
done

Install HACMP 5200 and Corrective Maintenance.

mount mx0apnim01:/export/lpp_source/hacmpes /mnt
cd /mnt/hacmpes_5200
/usr/lib/instl/sm_inst installp_cmd -a -l -d '.' -f 'bos
        ALL  @@S:bos _all_filesets,bos.clvm
         ALL  @@S:b
os.clvm _all_filesets,cluster.es                                                         ALL
 @@I:cluster.es _al
l_filesets,cluster.es.clvm                                                    ALL  @@I:cluste
r.es.clvm _all_file
sets,cluster.es.cspoc                                                   ALL  @@I:cluster.es.c
spoc _all_filesets,
cluster.license                                                    ALL  @@I:cluster.license _
all_filesets,rsct.b
asic                                                         ALL  @@S:rsct.basic _all_fileset
s,rsct.compat.basic
                                                  ALL  @@S:rsct.compat.basic _all_filesets,rs
ct.compat.clients
                                              ALL  @@S:rsct.compat.clients _all_filesets,rsct
.core
                                            ALL  @@S:rsct.core _all_filesets'  '-c' '-N' '-g'
 '-X'   '-V2'  '-Y'

Install HACMP 5200-01 Maintenance Level.

cd /mnt/hacmpes_5200-01
/usr/lib/instl/sm_inst installp_cmd -a -d '.' -f '_update_all'  '-c' '-N' '-g' '-X'  '-V2'  '-Y'

Install HACMP 5200-01 APAR#IY58496.

cd /mnt/hacmpes_5200-01_IY58496
/usr/lib/instl/sm_inst installp_cmd -a -d '.' -f '_update_all'  '-c' '-N' '-g' '-X'  '-V2'  '-Y'

Install HACMP 5200-01 APAR#IY77379.

cd /mnt/hacmpes_5200-01_IY77379
/usr/lib/instl/sm_inst installp_cmd -a -d '.' -f '_update_all'  '-c' '-N' '-g' '-X'  '-V2'  '-Y'

Install HACMP 5200-01 Efix#051116 for VIOS_MPIO.

cd /mnt/hacmpes_5200-01_Efixes_
emgr -e vios_mpio.051116.epkg.Z

Install HACMP 5200-01 Efix#051011 for Disk Heartbeat Failure.

cd /mnt/hacmpes_5200-01_Efixes_
emgr -e iy77276.051011.epkg.Z

Install HACMP 5200-01 Efix#051118 for IOSTAT.

cd /mnt/hacmpes_5200-01_Efixes_
emgr -e iostat_53D.051118.epkg.Z

Install HACMP 5200-01 Efix#051130 for TOPAS.

mount mx0apnim01:/export/lpp_source/aix/efix_051130 /mnt2
cd /mnt2
emgr -e topas_cec.051130.epkg.Z
cd /
umount /mnt2

Configure NTP CONF File for Time Protocol Daemon.

vi /etc/ntp.conf
     server 146.61.47.25 prefer
     server tick.cs.unlv.edu
     server wuarchive.wustl.edu
     tracefile /etc/ntp.trace
stopsrc -s xntpd
startsrc -s xntpd
xntpdc
     xntpdc >  sysinfo
     xntpdc >  quit

System Profile Configuration.

vi /etc/profile
PS1="`uname -n`:"'$PWD#'; export PS1

Sendmail Configuration.

Add the relay hostname to the sendmail configuration file.
vi /etc/sendmail.cf
	#DSmailer:relayhostname
	DSmail-relay.mtxia.com

Performance Monitoring configuration.


ssh root@$( hostname ) 'mkdir /usr/local/bin'
scp wlmsettag.aixbin root@$( hostname ):/usr/local/bin
ssh root@$( hostname ) 'chmod 755 /usr/local/bin/wlmsettag'

/usr/bin/ksh93
AIXSYS="$( hostname )"
AIXSYS="${AIXSYS%%.*}"
NFSSRV="mx1apnim01"
MTPT=( /prfpmce0 /prfdmce0 )  # Array of mount points 0=MX0 1=MX1
print "AIXSYS=${AIXSYS}    NFSSRV=${NFSSRV}"

umount ${MTPT[1]}
/usr/sbin/rmnfsmnt -f ${MTPT[1]} -BIXSYS="$( hostname )"
/usr/sbin/mknfsmnt -f '/prfdmce0' -d '/prfdmce0' -h 'mx1apnim01' -m 'rw' -M 'sys' '-B'  \
'-A' -t 'rw' -w 'bg' '-Y' '-Z' '-X' '-H' '-j' '-q' '-g'
mount ${MTPT[1]}
grep -p "${MTPT[1]}:" /etc/filesystems
df

rmitab ptxwlm
rmitab ptxtrend
mkitab "ptxwlm:2:respawn:/usr/bin/xmwlm -d ${MTPT[1]}/${AIXSYS}/wlm -n
xmwlm > /dev/null 2>&1 # Start xmwlm"
mkitab "ptxtrend:2:respawn:/usr/bin/xmtrend -f /etc/perf/jtopas.cf \
-d ${MTPT[1]}/${AIXSYS}/Top -n jtopas > /dev/null 2>&1 # Start trend"
egrep "^ptxwlm:|^ptxtrend:" /etc/inittab

for PID in  $( ps -ef -F pid,args | egrep 'xmwlm|xmtrend' | 
grep -v grep | awk '{ print $1 }' )
do
  print kill ${PID}
  kill ${PID}
  sleep 1
  print kill -9 ${PID}
  kill -9 ${PID}
done

ps -ef -F pid,args | egrep 'xmwlm|xmtrend'

nohup /usr/bin/xmwlm -d ${MTPT[1]}/${AIXSYS}/wlm -n xmwlm > /dev/null 2>&1 &
nohup /usr/bin/xmtrend -f /etc/perf/jtopas.cf -d ${MTPT[1]}/${AIXSYS}/Top \
-n jtopas > /dev/null 2>&1 &

MOTD Message of the Day Configuration.


System Herald Configuration.


Base User Security.


PLM Configuration.


TUXPRO Installation and Configuration.


Password Change for Root User.


Change Ticket for LOS Manager Turnover.


Update Frame/System Spreadsheet to EPERF.


ODM Error Notify to Tivoli TEC.


SNMP Integration into System Startup.

xmpeek -l hostname

Tune System Memory VMTUNE.


Tune TCPIP Parameters.

Disable Ipv6

Validate Standard System Build Components.










---------------- Required Configuration Sections ----------------

Tivoli TEC Configuration Tasks

Tivoli TEC Configuration and Verification Tasks.

Remove all additional LCF directories not in use.
	Ex.	rm -R /etc/Tivoli/lcf/2
	Ex.	rm -R /etc/Tivoli/lcf/3
	Ex.	rm -R /opt/tivoli/lcf/dat/2
	Ex.	rm -R /opt/tivoli/lcf/dat/3

Remove all additional LCF startup lines from /etc/inittab file.
	Ex. 	tma:2:once:/opt/tivoli/lcf/dat/2/lcfd.sh > /dev/console 2>&1
	Ex. 	tma:2:once:/opt/tivoli/lcf/dat/3/lcfd.sh > /dev/console 2>&1

Stop Tivoli endpoint if running.
	ps -ef |grep lcf
	/opt/Tivoli/lcf/dat/1/lcfd.sh stop

Edit/Add the following three lines from /opt/Tivoli/lcf/dat/1/last.cfg file. 
	lcs.machine_name="system_hostname"
	lcs.login_interfaces=mx0iatmr01+9494
	local_ip_interface="146.61.xxx.xxx"

Start the Tivoli endpoint client agent.
	/opt/Tivoli/lcf/dat/1/lcfd.sh start
 
Verify the Tivoli Endpoint is Connected to Tivoli database.
	From a network browser type :
		http://hostname:9495
	Verify Correct Output :
		Endpoint Label : hostname
		Hostname : hostname
		NIC Address : IP ADDRESS+9494
		Status : running
 
Verify/Add the following Lines from the /etc/inittab File.
	rctma1:2:off:/etc/rc.tma1 > /dev/console 2>&1 # Tivoli Management Agent
	tma:2:once:/opt/tivoli/lcf/dat/1/lcfd.sh > /dev/console 2>&1

Return to Tivoli TEC Client Installation

TSM Configuration Tasks

TSM Configuration and Verification Tasks.


Add the correct TSM Server Name in the /usr/tivoli/tsm/client/ba/bin/dsm.sys file.
 Ex.	TCPServeraddress   mx0aptsm01

Add the following startup lines to the /etc/inittab file.
tsm1::once:/usr/tivoli/tsm/client/ba/bin/dsmc sched> /dev/null 2>&1  #TSM Scheduler
tsm2:2:off:/usr/tivoli/tsm/client/ba/bin/dsmcad > /dev/null 2>&1 #TSM Client Web Interface

Start the TSM Scheduler.
nohup /usr/tivoli/tsm/client/ba/bin/dsmc sched &

TSM Compatability Website: http://sysa/storage/tsm.htmls :
For AIX 4.2.1
	tsmclient_
For AIX 4.3.3	
	tsmclient_5162
For AIX 5.1.0 - AIX 5.3.3	
	tsmclient_5234_32bit
	tsmclient_5234_64bit

Return to TSM Client Installation

SSH Configuration Tasks

SSH Configuration and Verification Tasks.


Add the System being built to the Systems Keys List File on the MX1 NIM Server.
vi /.ssh/AKeys/AixKeys.lst

Copy the authorized Keys from the MX1 Nim server.
scp -p /.ssh/AKeys/authorized_keys hostname:/root/.ssh/

Return to SSH Client Installation

System Dump device Configuration Tasks

System Dump Configuration Tasks.

Remove the uu file

Return to Create System Dump Device










---------------- Related Topics and References ----------------

Remove a machine from NIM

Remove a defined machine within NIM to recreate the system.

nim -o remove hostname-pers

Return to Define a Machine

Reallocate and Deallocate Resources from NIM Machine

Reset and Deallocate all Resources on defined machine

nim -o reset -a force=yes hostname-pers
nim -Fo deallocate -a subclass=all hostname-pers

Return to Define a Machine

Remove a Resource from NIM

Remove a NIM Resource.

nim -o remove resource_name

Return to Define a mksysb Resource.

go to createlpar

-
LPAR P5 Standard Builds
-
 

LPAR GENERIC BUILD
MX0ADEDN01 BLD DOC
MX0ADEDN02 BLD DOC
MX0ADEDN03 BLD DOC
MX0ADEDN04 BLD DOC
MX0ADEDN05 BLD DOC
MX0ADEDN06 BLD DOC
MX0ADEDN07 BLD DOC
MX0ADEDN08 BLD DOC


LPAR Leasing
Lease an AIX / i5 LPAR
Reduce your costs

www.mtxia.com

Server Leasing
Lease a Server off-site
Reduce your costs

www.mtxia.com

Data Center Automation
Business Continuity and DR
Virtualization/Consolidation

www.mtxia.com

HMC Service
Hardware Management Console
Manage Remote AIX / i5 LPARs

www.siteox.com

Business Web Site Hosting
$3.99 / month includes Tools,
Shopping Cart, Site Builder

www.siteox.com

FREE Domain Registration
included with Web Site Hosting
Tools, Social Networking, Blog

www.siteox.com

Disaster Recovery
Small Business Oriented
Off-Site Facilities

www.mtxia.com

IBM pSeries / iSeries
Reduce your Costs
Off-Site Server Hosting

www.mtxia.com