Home About BC DR HA Support Training Download
You are here: Home/ Business-Continuity/ Please Login or Register

Additional documents of interest

  • Successful Business Continuity - Part 1 - Users and Groups
    This article was published in the April 2005 issue of AIX Update magazine and discusses system administration needs and requirements oriented around users and groups. The overall emphasis of this series of articles is for implementation of enterprise wide unique identifiers for a variety of parameters, such as user names, group names, UID and GID numbers.
  • Successful Business Continuity - Part 2 - Machine and Host Names
    This article was published in the May 2005 issue of AIX Update magazine and discusses naming structures for machines, systems, adapters, and aliases. The overall emphasis of this series of articles is for implementation of enterprise wide unique identifiers for a variety of parameters.
  • Successful Business Continuity - Part 3 - Volume Names
    This article was published in the December 2005 issue of AIX Update magazine and discusses naming structures for volume groups, logical volumes, log logical volumes, directory mount points, etc. The overall emphasis of this series of articles is for implementation of enterprise wide unique identifiers for a variety of parameters.
  • Successful Business Continuity - Part 4 - MQ Series, Startup/Shutdown Scripts, Error Processing
    This article was published in the April 2006 issue of AIX Update magazine and discusses how to implement AIX in an environment dedicated to business continuity. The topic of this article is the assignment of MQ Series queue names and aliases, resource group startup and shutdown script names (Application startup/shutdown script names), error logging, and error notification.
  • Successful Business Continuity - Part 5 - Miscellaneous topics
    This article was published in the August 2006 issue of AIX Update magazine and discusses how to implement AIX in an environment dedicated to business continuity. A variety of topics is discussed in this article including automated documentation generation and management.
  • Automated Microcode Management System
    One of the most difficult administration tasks in an AIX environment is attempting to keep the firmware and microcode up-to-date. Mt Xia has devised an automated method of gathering the Microcode information, determining which microcode needs to be updated, generating reports, and uploading the required microcode updates to each individual system.
  • Calculating the size of a Virtual Processor
    This document describes the algorithms used to calculate the size of a virtual processor when using shared processors in an LPAR. The IBM documentation describes how to calculate CPU utilization, NOT how to size for configuration, this document clarifies this process. A description of the HMC input fields for the processor tab is included.
  • Basics of Partition Load Manager Setup
    This presentation was provided by Ron Barker from IBM regarding the PLM Basic setup.
  • ppt
  • pdf
  • The following procedure is specific to an LPAR named "daladcal01" but is representative of how to configure etherchannels on all virtual LPAR's utilizing network adapters being provided from dual VIO servers.


    procedure|LPAR etherchannel configuration of daladcal01| see below
    
    
    # On the client LPAR, unconfigure all ethernet adapters
    lscfg -l ent*
    for i in 8 7 6 5 4 3 2 1 0
    do
      ifconfig en${i} down
      ifconfig en${i} detach
      ifconfig et${i} down
      ifconfig et${i} detach
      rmdev -Rdl ent${i}
      rmdev -Rdl en${i}
      rmdev -Rdl et${i}
    done
    ifconfig -a
    lsdev -Cc adapter | grep ent
    
    
    # Rediscover all ethernet adapters
    cfgmgr
    lsdev -Cc adapter | grep ent
    lsdev -C | grep inet
    lsdev -C | grep lo
    lscfg -l ent*
    
    
    # turn off the chksum_offload parameter on all adapters
    for i in 8 7 6 5 4 3 2 1 0
    do
      lsattr -El ent${i} | grep chksum_offload
      chdev -l ent${i} -a chksum_offload=no
      chdev -l ent${i} -a chksum_offload=no -P
      lsattr -El ent${i} | grep chksum_offload
    done
    
    
    # Configure etherchannel devices, begin by removing existing adapters
    for i in 6 7 8
    do
      rmdev -Rdl ent${i}
      rmdev -Rdl en${i}
      rmdev -Rdl et${i}
    done
    
    # ent0 and ent1 should represent virtual ethernet adapters shared
    # from the VIO servers via slots 500 and 505.
    # The netaddr points to the subnet gateway for the boot/service 
    # network, used for health check.
    if mkdev -c adapter -s pseudo -t ibm_ech \
       -a adapter_names='ent0,ent1' \
       -a netaddr=10.33.65.254
    then
      /usr/lib/methods/defif
    fi
    
    # ent2 and ent3 should represent virtual ethernet adapters shared
    # from the VIO servers via slots 850 and 855.
    # The netaddr points to the subnet gateway for the "man" network, 
    # used for health check.
    if mkdev -c adapter -s pseudo -t ibm_ech \
       -a adapter_names='ent2,ent3' \
       -a netaddr=10.33.68.254
    then
      /usr/lib/methods/defif
    fi
    
    # ent4 and ent5 should represent virtual ethernet adapters shared
    # from the VIO servers via slots 900 and 905.
    # The netaddr points to the subnet gateway for the boot/service 
    # network, used for health check.
    if mkdev -c adapter -s pseudo -t ibm_ech \
       -a adapter_names='ent4,ent5' \
       -a netaddr=10.33.65.254
    then
      /usr/lib/methods/defif
    fi
    lsdev -Cc adapter | grep ent
    
    # configure IP addresses on etherchannels
    smitty tcpip
    
    # daladcal01-boot: en6: 10.33.65.214
    # daladcal01-man : en7: 
    # daladcal01-stby: en8: 
    
    ################################################################
    
    procedure|LPAR etherchannel configuration of daladcal02| see below
    
    # Unconfigure all ethernet adapters
    lscfg -l ent*
    for i in 8 7 6 5 4 3 2 1 0
    do
      ifconfig en${i} down
      ifconfig en${i} detach
      ifconfig et${i} down
      ifconfig et${i} detach
      rmdev -Rdl ent${i}
      rmdev -Rdl en${i}
      rmdev -Rdl et${i}
    done
    ifconfig -a
    lsdev -Cc adapter | grep ent
    
    
    # Rediscover all ethernet adapters
    cfgmgr
    lsdev -Cc adapter | grep ent
    lsdev -C | grep inet
    lsdev -C | grep lo
    lscfg -l ent*
    
    # turn off the chksum_offload parameter on all adapters
    for i in 8 7 6 5 4 3 2 1 0
    do
      lsattr -El ent${i} | grep chksum_offload
      chdev -l ent${i} -a chksum_offload=no
      chdev -l ent${i} -a chksum_offload=no -P
      lsattr -El ent${i} | grep chksum_offload
    done
    
    
    # Configure etherchannel devices
    for i in 6 7 8
    do
      rmdev -Rdl ent${i}
      rmdev -Rdl en${i}
      rmdev -Rdl et${i}
    done
    
    if mkdev -c adapter -s pseudo -t ibm_ech \
       -a adapter_names='ent0' \
       -a netaddr=10.33.65.254 \
       -a backup_adapter=ent1
    then
      /usr/lib/methods/defif
    fi
    if mkdev -c adapter -s pseudo -t ibm_ech \
       -a adapter_names='ent2' \
       -a netaddr=10.33.68.254 \
       -a backup_adapter=ent3
    then
      /usr/lib/methods/defif
    fi
    if mkdev -c adapter -s pseudo -t ibm_ech \
       -a adapter_names='ent4,ent5' \
       -a netaddr=10.33.65.254
    then
      /usr/lib/methods/defif
    fi
    lsdev -Cc adapter | grep ent
    
    # configure IP addresses on etherchannels
    smitty tcpip
    
    # daladcal02-boot: en6: 10.33.65.216
    
    
    

    -
    LPAR Ether Config
    -
     


    LPAR Leasing
    Lease an AIX / i5 LPAR
    Reduce your costs

    www.mtxia.com

    Server Leasing
    Lease a Server off-site
    Reduce your costs

    www.mtxia.com

    Data Center Automation
    Business Continuity and DR
    Virtualization/Consolidation

    www.mtxia.com

    HMC Service
    Hardware Management Console
    Manage Remote AIX / i5 LPARs

    www.siteox.com

    Business Web Site Hosting
    $3.99 / month includes Tools,
    Shopping Cart, Site Builder

    www.siteox.com

    FREE Domain Registration
    included with Web Site Hosting
    Tools, Social Networking, Blog

    www.siteox.com

    Disaster Recovery
    Small Business Oriented
    Off-Site Facilities

    www.mtxia.com

    IBM pSeries / iSeries
    Reduce your Costs
    Off-Site Server Hosting

    www.mtxia.com